The Bug Genie team blog

What's cooking behind the scenes of The Bug Genie

Version 3 minimum requirements – personal opinion

leave a comment »

Disclaimer: This is my personal opinion, and may not reflect the opinion of the rest of the team.

I definately see the background for this discussion. While we’re currently running a distribution that supports PHP 5.3 I understand that some (many?) of you don’t. Please let me explain a little detail about the PHP versions before you decide where to cast your vote.

I understand that you may be running a specific linux / unix distribution and want to use the version of PHP that follows it. PHP 5.2.6, however, was released 01. May, 2008, and is currently 2 and a half years old. For a language that deals with web technology and related software stacks, this is not only terribly outdated, but also has severe security, performance and reliability issues. The current version of PHP 5.2 is 5.2.14, and is also the last planned to be released in the 5.2.x series. PHP 5.2 is currently a discontinued version of PHP.

PHP 5.3 was released 30th June, 2009 – it is already almost a year and a half old. While it may not be available by default in the current version of your distribution, packages for PHP 5.3 is available for pretty much any operating system out there. PHP 5.3 includes performance and memory improvements across the entire stack, as well as a boatload of new and important features to keep the language up-to-date and competitive.

Even if upgrading to 5.3 is not a desired option, upgrading to the latest version of PHP 5.2 should be a minimum. Packages for 5.2.10 are available for both Debian distributions Lenny and Etch, and for Lenny, 5.2.14 is available (both these from http://dotdeb.org), and most other distributions have packages for more recent versions of PHP. Ubuntu, for instance has had version 5.3 as the default in the last two releases.

We haven’t decided on this yet, but as late as today I had to choose an approach that required me to refactor the entire codebase to get it to do what I wanted, because I didn’t want to introduce a 5.3-specific feature that would be very hard to unimplement. Please keep in mind that sticking to 5.2.x will limit our capabilities, regardless of good intentions.

About these ads

Written by zegenie

October 20, 2010 at 13:26

Posted in The Bug Genie 3.0

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 845 other followers

%d bloggers like this: